A4 B6 1.9tdi 130 AC issues

Hi all
I'm looking for assistance with my aircon on my B6 A4.
The long and short of the problem is the aircon sometimes works brilliantly, kicking out ice cold air, while other times it's barely any cooler than opening the window!

So far I have had the system fully drained, vacuumed and refilled with the correct amount of gas (500g if memory serves). 345g was retrieved during this process so while it was lower than optimum, it had never ran out.
I have replaced the G65 sensor
I have replaced the HVAC controller for the last B6 MY04 variant
I have checked for fault codes, there has been none.
I have opened every single cabin blend motor, and lubricated the motor gears with silicone oil, and then run a aircon recalibration on VCDS.

It's a really odd issue. Often it manifests itself during a long journey as the trip starts with ice cold air but then it get's warmer and warmer. I believe I have captured the results on VCDS but never are any faults recorded.

When it's working correctly I see this in VCDS
IMG_20210803_202349.jpg

IMG_20210803_202604.jpg

IMG_20210803_202916.jpg


IMG_20210803_202955.jpg


Today I decided to change the G65 sensor for a new version just in case it was faulty. A new Mahle sensor is now fitted but it has made no difference and after a drive the system warmed back up so I captured it on VCDS and it looked like this
IMG_20210810_132351.jpg


IMG_20210810_132451.jpg


If anyone can point me in the right direction I would be grateful. I don't believe it's a gas issue, and G65 is new. Any other ideas?
Thanks in advance :)
 
Last edited:
No one? Can anyone recommend a forum more focused on Aircon issues if not?
 

rum4mo

Registered User
Well, maybe some things to consider, did you use a general tyre/exhaust etc place to recharge the system, or a proper AC place?

If it was the former, they would not have enough knowledge normally to monitor the system while it was operating, just qualified to handle fridge gas and operate a dumbed down charging station.

Even although this problem is unpredictable - ie can't be trusted to happen at a convenient time, it could be worth while to hand this car over to a proper AC person as they could monitor the behaviour of both sides - this should give them enough confidence, with your permission, to replace any parts that might be causing a restriction to the flow of the R134a, it might just be still too much moisture in the system causing ice particles to collect at a throttling point and so reducing or spotting the normal flow of R134a, after this has happened thing will not improve until the car has been left, or at least the AC disabled long enough for these frozen bits of moisture to turn back into moisture in the charge. That is just one example of what might be happening.
 
Thanks for the advice, that makes a lot of sense. I've discovered there is an inline filter that can also get blocked over time which might be worth changing once the system is drained. I'll see who my aircon specialists are in the area.
 
Top