A4 cabriolet electric rear window and roof problems

newboy1234

Registered User
Exactly what is the problem?
Thanks Darren I have a 2003 52 reg The problem is there is no power getting to the back passenger window I had bought a replacement motor for it as it did have power and I thought it must be motor as the regulator side of it look complete. I Have had the carpet up to check for water and the carpet is very damp but all connections to module are ok no corrosion inside looks OK as well all other Windows work fine I was told it's probably a fuse but which one I don't know. The roof does not operate I think because that window doesn't work when you press the button message comes up soft top cannot be used. I also have problem with imobiliser say low power
 

newboy1234

Registered User
Can you give us a bit more info please. What is the roof and window doing? Year of the car? Have you had the car scanned for fault codes?
I have a 2003 52 reg The codes that come up are switch implausaible for the roof and says on dash roof cannot be used The window did have power going to it so i thought the motor had gone so bought replacement but then there was no power getting to it The code reader said it was in single wire mode could not comunicate code reader was Autel vag 505
 

newboy1234

Registered User
Thanks for getting back to me Im getting it scanned tommorow in oxford theres a guy there thats going to see whats going on. Ive got some other issues the alarm does work i think but no sound and the parking sensors make a long beep when put in reverse but then when i reverse stop.
 

mattmanwrx

Used to have a wrx. Now an S4
VCDS Map User
Thanks for getting back to me Im getting it scanned tommorow in oxford theres a guy there thats going to see whats going on. Ive got some other issues the alarm does work i think but no sound and the parking sensors make a long beep when put in reverse but then when i reverse stop.

My alarm box had leaked when I bought my S4 cab. Just needed changing out. Luckily for me it was on a warranty so I just had it changed. The batteries leak everywhere, very common. Just have the hazard lights flashing, no sound.

To gain access to it; put the roof down, put the roof up, but stop it very early on, when the lid lifts up. Then there is the box on the driver's side.
 

newboy1234

Registered User
Thanks I'll check it out I've now got my rear window and roof working turned out to be broken wire in rear footwell replaced wire all good parking sensor problem was faulty left sensor .
 
Top