Alternator fault- battery not charging.

johnnevett

Registered User
Hi all,
Driving home from work today and got the message 'alternator fault- battery not charging'
Checked the battery level and it was at 70%.
In start stop traffic the battery was dropping and the revs wouldn't go below 1000
Turned off heater, radio and lights hoping this would help the battery level as it was dropping quite fast
The level got to 10% and I feared the worse.
Then, the message disappeared from the display and the battery started charging and the revs went back to normal.
By the time I got home the battery had reached 90%
Has anyone experienced this problem? Is this just a little glitch or do you reckon the alternator is on its way out?
Want to price up a new one just in case, does anyone know the rating/ part number for an alternator for a 2008 2.0tdi.
Thanks.
 

xpoweruk

TTTS 8J Smile Machine
I think Audi have some sort of battery management controller that could possibly be at fault
 

stu3.0

only grey in my village.
hello. do you know the location of the battery management controller.thanks
 

stu3.0

only grey in my village.
hello. in the boot. ? my battery is under the bonnet not in the boot. A4 3.0 petrol.
 

stu3.0

only grey in my village.
i dont think the battery is no good as ive tried 3 different batterys and all eventually wont start the car up. having to jump start of a charged battery.
 

stu3.0

only grey in my village.
sorry mine is a b6 a4 3.0 quattro. any idea if that model has a controller. thanks
 

stu3.0

only grey in my village.
sorry how do i find the b6 section. didnt realise i was in the wrong area. just clicked on this thread has it came up in results to my original post/reply. thanks
 

stu3.0

only grey in my village.
i found it thanks. hope some one can help can do without buying new alternator if not needed.its strange it makes power to run car but not charge battery
 
Top