Audi A7 warning lights

Hal7

New Member
I had recently taken my car to Halfords to get a dash cam fitting, and after it was fitted there seemed to be couple warning lights:
1) steering system fault
2) Audi adaptive light fault.
3) left and right beam fault
4) main beam assist fault

im not quite sure what’s wrong with it but they couldn’t fix it aswell, it might be the fuse fryed up or something.
my car has been with Audi for more than a week and have said the diagnostics will cost £600 and I’m still waiting on the quote.

Can anyone help
24F35F81-939E-44BD-A8C8-6E116FD384A7.jpeg
2B1199F8-DC15-425D-A960-55F25A216A85.jpeg
F19E4B69-3D56-4323-8A97-DC3AEAA813E9.jpeg
77B37BE1-DFEA-4529-89F1-93499DC00BB8.jpeg
 

RAF_S7

Well-Known Member
Gold Supporter
It sounds like a power issue caused by Halfords tapping into power somewhere they shouldn’t have :blink:
I would have gotten someone with VCDS to scan the car to diagnose what was triggering the failure.

I hope Halfords will be picking up the costs..

Good Luck.
John :hi:
 

+robster+a7+tdi

Registered User
logic says take a step back. ( like windows restore point )
First try disconnect dash cam power to rule out inteference on the windscreen as you may have sensitive radar or camera near where the dash cam is mounted that will be required to work correctly for adaptive light levelling
is it all related to right hand headlight ? is bulb working? maybey it has those turning headlights that take an input from the steering wheel position sensor?
must all be related somewhere.
just try remove the dash cam power and if it is tapped into a spare fuse box supply or piggy backed of an existing fuse the circuit may not like the extra load especially from a cheap 12v to 5v dash cam power supply .
 

+robster+a7+tdi

Registered User
the symbol with the red cross means bulb circuit monotoring ( bulb blown) (or canbus error like your typical low resistance led light canbus errors) get halfords to undo the install and start a fresh.
otherwise id be concentrating on central electrics module 09
 
Last edited:

Hal7

New Member
It sounds like a power issue caused by Halfords tapping into power somewhere they shouldn’t have :blink:
I would have gotten someone with VCDS to scan the car to diagnose what was triggering the failure.

I hope Halfords will be picking up the costs..

Good Luck.
John :hi:
Yh god knows what they have done, anyone know a good place in London that can sort it out
 

RAF_S7

Well-Known Member
Gold Supporter
Yh god knows what they have done, anyone know a good place in London that can sort it out
I believe one of the forum sponsors is London based - @NHN if I recall correctly. Good place to start :thumbs up:
 

beemerboy9

Registered User
Yh god knows what they have done, anyone know a good place in London that can sort it out
I can highly recommend Creative Car Sounds in Winchmore Hill., North London who did the Nextbase dashcam install on my A6 C7.

He did the stereo upgrade on Rowan Atkinson's McLaren - and that would have been a highly specialized installation.
 
Top