clunk clunk clunk

tubby-ben

Registered User
well after a few months finally got some spare time and taken my car to a local mechanic to sort out a bogus clunk.
2 garages couldnt find what it was so i left it and left it and left it, that is until i couldnt put up with the clonking any more.
hopefully fingers crossed it wont be much to fix and having my step dad who owns a car spares shop i will get the parts trade.
after this i will be sorting out some coilovers, arb's better braking system, induction kit and remap.
 

tubby-ben

Registered User
can you describe the clunk? when does it do it and where does it sound like its coming from?
lower front of car , drivers side , seems to be around the pedal box area but noise does travel. it makes a clunking/rattle sound when road is uneven like when pot holes etc .
i should find out tomorrow hopefully...........
 
Or ARB droplinks.
 

tubby-ben

Registered User
cheers markeyboy yeah i hope its nothing major as im wanting to spend some wedge on tuning her up a little.
your forge 007p who does these cheap? ive been offered a split-r second hand pretty cheap. have the agu engine. any experience with the split-r?
 

Markeyboy

Fan of the R-Tech!
Best place to get the 007p is eBay, never seen it any cheaper else where,

Never used a splitter r, it does let some metered air out of the boost vac system which isnt a great thing considering it's a metered system

I ran mine with a dv26 which sounded great but did cause it to run like a pig after about a month
 
Top mounts sitting ok as they can sound like they are coming from the bottom of the car when there gone, I know this because mine went on the weekend when I hit a pothole!!
 

A3tell

Registered User
Would be interested to see what the outcome of this is, as it sounds as if it the exact same thing I have on my car!!! Had it since I put my coilovers on, and b4 people ask, I replaced both top mounts when I changed them.
I did however notice when I had the drivers side wheel off the other day, that the wishbone bush seemed a bit battered!!! Might be something to check on yours!
 

L33h

Registered User
Is it lowered?

Mines a tiny bit too low on the drivers side and it nocks when the ARB touches the driveshaft.

This has just reminded to to nock it up a touch :)
 

AARON77

Registered User
I had a knocking noise that took me ages to find, turned out to be the drop links
its worth trying them coz they cheap to fix
you should be able to wiggle them to see if there's any play in them
 

tubby-ben

Registered User
ok so i went to pick the car up from my mechanic who also happens to rent his workshop from my step dad who owns a car spares shop and was horrified to see the state of both lower wishbones. omg is an understatement.... all the rubber mounts were shot to bits, and the mechanic said i was lucky to not have a complete front end failure, so both replaced and with new ball joints built in too. took her for a test drive to find the knocking i have is still there but quieter and less often but still there. we jacked the car back up and go under it, pulled/pushed about everything we could see and nothing was found broken or worn. All mounts checked as in engine , gearbox, arb, top mounts, just dont know what else it can be. im thinking of just buying JOM coilovers, putting them on and hope for the best. i have heard of struts braking up inside and i do want to uprate the suspension. fingers crossed....
 

Markeyboy

Fan of the R-Tech!
its good that it was caught before it really failed,

it took me some time to find my knock, i did the top mounts first with no change, then both lower arms which got a little better, arb bushes as next which solved it for me

best of luck finding it
 

tubby-ben

Registered User
cheers dude, yeah im gunna go ahead and start tuning the old girl up, hopefully by changing a few bits it may cue the problem.
is the 3" downpipe u got fitted a good investment?
 

L33h

Registered User
Im guessing you've checked for play on the wheels?

ARB bushes sound likely to me too. Ive recently had to change mine.
 

tubby-ben

Registered User
Im guessing you've checked for play on the wheels?

ARB bushes sound likely to me too. Ive recently had to change mine.
had play in passenger side wheel but minimal, ive new lower wishbones fitted now with new ball joints so now play has gone, and the ARB bushes look mint.. im going to get a coilover setup anyway and going to change ARB so will get new bushes. cheers buddy...
 

Markeyboy

Fan of the R-Tech!
cheers dude, yeah im gunna go ahead and start tuning the old girl up, hopefully by changing a few bits it may cue the problem.
is the 3" downpipe u got fitted a good investment?

yea mate, really worth the money, turbo spool much quicker when standard, very good piece of kit
 
Top