Coding out Brake wear sensor?

Daveyonthemove

Well-Known Member
VCDS Map User
I recently had the wear sensor flash p on my dash, and it won't go away.
The pads on all four corners have plenty of meat left on them, they were all changed less than 50k miles ago.
Upon inspection, the cable on the wear sensor has been flapping around and made contact with the disc, and despite attempts to repair it the light won't go away.

I have trawled through all the settings in OBD11 to try and find a code to turn it off, but it doesn't exist.
I do have the ability to long code the car, but do not know the correct code to use to turn it off (if it's possible).

If anyone can offer advice on the correct code, that would be a massive help. The current code is: 0037418

Thanks is advance.
 

Daveyonthemove

Well-Known Member
VCDS Map User
You 100% sure it's a P?

You can twist the two wires together, and the light will go out.

Or follow this on youtube

8P? Yes, 2006 S3 BHZ
I don't really want to twist the cables unless it's the last resort. Coding is the best option if possible.

I have seen that video, but there is no option for the wear sensor on block 17 on mine.


That's handy, I will give it a try.
Looking at that, I add 1 to the current code to make it 0037419?
 

Daveyonthemove

Well-Known Member
VCDS Map User
Screenshot_20210307-171522_OBDeleven.jpg
 

LEE69

07 170 DSG
No that's not right the coding goes left to right, but your coding is already at 0 :/

That coding is for a mk4 and I thought it would be the same, but obviously not. From your options I can't see how to turn it off

See if @NHN gets the tag and can help
 

Daveyonthemove

Well-Known Member
VCDS Map User
Thanks for trying.
To make matters worse, I just ran a few output tests on some modules and now I have a defective adaptive headlight error!
No coding was changed in any module, and it still operates fully but there is a code.
 

Daveyonthemove

Well-Known Member
VCDS Map User
No problem, clear the code see if it comes back
It does, instantly.
I've locked the car up and will go back to it after i've eaten. Hoping the modules shutting down will give it a chance to figure out there is no error when I go back to it.
 

samuelh_888

Registered User
When I fitted my front BBK, the pads don’t have wear sensors. The guys who fitted it used an A5 sensor or something - plugged it into the S3 connector and have tied it to the strut. I’ll see if I can get more detail but it’s essentially the same as twisting the wires together and heat shrinking them.
 

aqibi2000

Registered User
When I fitted my front BBK, the pads don’t have wear sensors. The guys who fitted it used an A5 sensor or something - plugged it into the S3 connector and have tied it to the strut. I’ll see if I can get more detail but it’s essentially the same as twisting the wires together and heat shrinking them.

it’s a a chopped sensor cable/connector which has the wires soldered together
 

Daveyonthemove

Well-Known Member
VCDS Map User
I think mine may be faulty on the car side of the connector, not the brake pad.
The connector wasn't in the best condition and the wires above the pins feel a bit flimsy. I have a feeling I will either haver to crimp the wires together on the main harness, or find a replacement plug and solder it onto the existing wires.
 

Daveyonthemove

Well-Known Member
VCDS Map User
I may look to get one in the near future, but it will have to wait as I'm having to get the Cam chain and Cambelt done this weekend due to the chain rattling.
I've had so many trouble free miles with this car, and now it want's everything all at once!
 
I may look to get one in the near future, but it will have to wait as I'm having to get the Cam chain and Cambelt done this weekend due to the chain rattling.
I've had so many trouble free miles with this car, and now it want's everything all at once!
Can I ask how much it’s costing to do both please if you don’t mind? I’ve been looking so expecting around the 800-850 range.
 

Daveyonthemove

Well-Known Member
VCDS Map User
Can I ask how much it’s costing to do both please if you don’t mind? I’ve been looking so expecting around the 800-850 range.
Been quoted £800 for the all parts and labour, which I believe is mates rates so probably a few hundred cheaper than a main dealer or indy garage might charge.
For context, I got the Cambelt done 3 years ago by a VAG specialist for approx £350 (from memory) and the same garage is charging £444 on their website today.
 
Been quoted £800 for the all parts and labour, which I believe is mates rates so probably a few hundred cheaper than a main dealer or indy garage might charge.
For context, I got the Cambelt done 3 years ago by a VAG specialist for approx £350 (from memory) and the same garage is charging £444 on their website today.
Thank you helps validate what I’ve been looking at and pricing up for mine
 
Top