EML after downpipe install on B8 S4

KriS4

Registered User
Hello,

I have installed resonated downpipes on my B8 S4 last week.

All good but after a few miles of driving the Engine Management Light came on.

Got worried a little bit and plugged in my odb scanner to see of any error messages will be displayed.
Got 2 errors now P0161 and P0141.
I know these are something to do with the o2 sensors.
I can delete them but they come back on after few minutes of driving.
I once had the engine running bit louder, sounded like the fan is constantly running, but it was not. This went away after deleting the errors.
No other symptoms.

What went wrong?


Sent from my LG-H930 using Tapatalk
 

Ginge247

Registered User
Hello,

I have installed resonated downpipes on my B8 S4 last week.

All good but after a few miles of driving the Engine Management Light came on.

Got worried a little bit and plugged in my odb scanner to see of any error messages will be displayed.
Got 2 errors now P0161 and P0141.
I know these are something to do with the o2 sensors.
I can delete them but they come back on after few minutes of driving.
I once had the engine running bit louder, sounded like the fan is constantly running, but it was not. This went away after deleting the errors.
No other symptoms.

What went wrong?


Sent from my LG-H930 using Tapatalk
You don't even touch the o2 sensors when changing the dps. Did you fit them your self?

Sent from my JSN-L21 using Tapatalk
 

KriS4

Registered User
You don't even touch the o2 sensors when changing the dps. Did you fit them your self?

Sent from my JSN-L21 using Tapatalk
Did not touch them. Fitted by the garage.
Had to use bit of force, cutting and grinding to get the bolts out as all was rusted but did not go close to o2 sensors.
The new DP are 2.5" in diameter, but dont think this would cause the eml and the errors.

Sent from my LG-H930 using Tapatalk
 

Ginge247

Registered User
Did not touch them. Fitted by the garage.
Had to use bit of force, cutting and grinding to get the bolts out as all was rusted but did not go close to o2 sensors.
The new DP are 2.5" in diameter, but dont think this would cause the eml and the errors.

Sent from my LG-H930 using Tapatalk
I've got the remus 2.5" downpipes on and had no issues at all. The garage must have f#@ked something up when fitting them m8. I wonder if they have damaged the wiring somewhere?

Sent from my JSN-L21 using Tapatalk
 

KriS4

Registered User
I've got the remus 2.5" downpipes on and had no issues at all. The garage must have f#@ked something up when fitting them m8. I wonder if they have damaged the wiring somewhere?

Sent from my JSN-L21 using Tapatalk
I have asked the same question when the eml came on first time I went back to them and they said... we went not even close to the the o2 sensors.
Strange it is not one side, but both.

Sent from my LG-H930 using Tapatalk
 

Ginge247

Registered User
I have asked the same question when the eml came on first time I went back to them and they said... we went not even close to the the o2 sensors.
Strange it is not one side, but both.

Sent from my LG-H930 using Tapatalk
Yeah it's strange one. Could be the old sensors are going bad and don't like the increased flow. Have a look at this, not the same engine obviously but same codes
https://r.tapatalk.com/shareLink?ur...share_tid=591160&share_fid=17679&share_type=t

Sent from my JSN-L21 using Tapatalk
 

KriS4

Registered User
Have you had a map tweak since fitting the downpipes?
No, not yet. My understanding was that you do not need remaping if cats are still in place?
Had same thing with my MK5 GTI when had new downpipe fitted, but it was with sports cat so had to be remaped to get the CEL (EML) gone.

Sent from my LG-H930 using Tapatalk
 

Chets

Member
VCDS Map User
Not related to the original post but has anyone got any noise clips of the S4 after a DP install. I'm interested in going down this route but not sure if i'd like the sound. Any drone on motorway driving?
 

KriS4

Registered User
Not related to the original post but has anyone got any noise clips of the S4 after a DP install. I'm interested in going down this route but not sure if i'd like the sound. Any drone on motorway driving?
I hardly have any change when driving normally.
Slightly louder and deeper when flooring it.
I am quite dissappointed that DPs have not changed it that much.
Mine are resonated.
Maybe different brand would be different, louder. Mine are only cheap set of ebay which had to be customized to fit.
No drone on motorway at all.

Sent from my LG-H930 using Tapatalk
 
Top