heater motor intermittent

jbcalvin

Registered User
Hey guys,

I am having intermittent problems with my heater motor not working, the air-con controls are all fine and I can her the flaps moving around when I adjust where I want the heat to go, however the fan motor doesn't always work and sometimes just cuts out/restarts randomly...

Do I need a new motor, or can it be repaired, a new one is over £300!!!!!

I have a 1.9 TDI Quattro sport 52 plate with 100K on the clock...
 

ScottD3

I want your faulty electronics
Supporter
Sounds like the same fault the B5s have.
The bushes on the motor wear down and cause the fan to stop spinning.
You can buy new bushes off ebay for a couple of pounds.

Here it some pics of the motor from a B5

_MG_9706.jpg

_MG_9710.jpg


these pics are from my motor. I was having the same issue you was having.
I turned the bushes around in the hope the motor will last the winter.

GSF (other motor factors are available) will sell you the fan for alot less.
 

paul20v

Audi fanatic
You can buy new bushes off ebay for a couple of pounds.

I turned the bushes around in the hope the motor will last the winter.

There Brushes not bushes
also when renewing them it is adviceable to undercut the commutator a little and give it a clean ( thats where the brushes run on the spindle of the motor )
you do this because sometimes you get a build up between the sections of brush material and material off the Com itself .
 

jbcalvin

Registered User
Cheers guys,

I take it this is a fairly easy job, I'm reasonably technically minded and any idea how long it would take?
 

ressull

Registered User
Hi, I'm having the same problem as you with the heater on my 1.9 TDi A4 B6 model. I was advised to replace the fan brushes as posted above but when I removed the fan motor it is different to the one used on the B5 and I cant see any way of accessing the brushes (I have also read that it doesnt have any brushes on it which looks more likely). I've attached photos of my fan motor for reference.
attachment.php
attachment.php


Dont know about you but my blowers tend not to work in very cold weather and I have been advised to check out the heater element for the coolant system (which doesnt really mean much to me to be honest but I'l look into it).

If anyone has any further information on this then I'd love to hear it as I'm a bit stuck at the moment.

Thanks and I'l keep you posted if I find out any more.
 

Turkster

W.Bro.Paul 2.0d Q5 Quattro
getting the fan out is a real git of a job, glove box off and a good touch, iv got a great 2nd hand fan that is only done 40K miles in a B7, same as the B6.
 

ressull

Registered User
yeah, was a bit of a pain to get the fan out (not looking forward to putting it back in).

I'l keep your offer in mind but I'm starting to wonder if it is the fan that is causing the problem or if it is something else (ie. heater element etc).
 

jbcalvin

Registered User
Hi ressul

Thanks for the update on that, glad I didn't buy the brushes from e-bay last night, I think in my case it is the motor, it was working perfectly all last month, even at -15 on several early morning starts, temp is now well above freezing and it's only now playing up....

Turkster - if the fan you have will definitely fit my car then how much do you want for it? PM me with details....

If anyone else has other suggestions, let's have them....
 
Top