MMI view

Traffic Light Recognition requires Car2X to be fitted to the car. Whilst many A3 car reviews mentioned it as a feature, it’s not on the build configuration for my 2021 S-Line with the Driver Tech Pack. So I’m not sure whether it’s one of those features that gets introduced into the build line at a later date? I hope the 2020/21 cars have the capability, as the count-down to green feature looks really useful. (Assuming that it gets rolled out in U.K. infrastructure in the any time in the next decade.) Does anyone know: it’s one of the questions my dealer was unable to answer.
 

NIKLDN

A3 8Y 1.5 TFSI Edition 1
Did you spec the traffic light recognition, as thought that was one of the optional extras (though did think it was only on higher end models?)

The speed limit recognition so far looks like it's going be enabled as part of functions on demand whenever Audi decide to launch that.

Some members have been able to get Audi to agree to activate it for free once it's enabled. (I'm still fighting my dealer on that)
Software originally was Oct 19 it’s been updated to September 20 software but still no wireless CarPlay, the dealership even had 2 cars side by side one with 2019 and one with 2020 software numerous control units were swapped between the 2 cars and they didn’t get it working on the older car.
For me the CarPlay again isn’t a issue I brought a Audi for the Audi MMI.
My biggest complaint was the constant reboot of the system, I’ve had the car back a week now and it’s not rebooted once since they found the faulty on/off switch.
Only thing I want now for me to 100% happy is a spare wheel and Jack but I can’t get the part numbers to order one.
Dealers say it not a option on the TDI saloon.
So I went out this afternoon and behold, I started having a similar issue. Whilst my user was logged in, it would randomly kick me out and go back to the intro ‘please select user’ screen.

Parked up at the destination. An hour later, Got back to the car and more issues. SOS malfunction popped up and the MMI was just frozen on a loading screen. Tried to turn the MMI on and off, turn the car on and off, no joy. On one of the restarts, I even got a ‘parking aid assist’ error!

45 minutes later, pulled up to pick up a take away, was away from the car for 10 odd minutes, came back, turned it on and it was back to normal.

@SamB2020 have you had the SOS malfunction issue?
 

NIKLDN

A3 8Y 1.5 TFSI Edition 1
Have you got a spec sheet for your car?

Some of those are reliant on optional upgrades like the driver assistance pack being in place.

As Sam pointed out, no hope for the wireless carplay on older cars.

@SamB2020 - if I recall correctly yours (or maybe someone else's) software was updated but you were still missing the wireless carplay right?
Spec sheet? Don’t believe so. As mentioned before, the car is an ex demo car so not made to order like most of yous.

Hoping a coding genius out there can offer services to fill the gap.
 

Nothingdoing079

Registered User
Spec sheet? Don’t believe so. As mentioned before, the car is an ex demo car so not made to order like most of yous.

Hoping a coding genius out there can offer services to fill the gap.
If you have the myaudi app installed and linked then you can find the spec sheet under the "my vehicle in detail" section.

That seems to list everything that the car comes with/has available for activating once FOD goes live.
 

NIKLDN

A3 8Y 1.5 TFSI Edition 1
If you have the myaudi app installed and linked then you can find the spec sheet under the "my vehicle in detail" section.

That seems to list everything that the car comes with/has available for activating once FOD goes live.
ah I’ll check this out, and FOD?
 

Nothingdoing079

Registered User
ah I’ll check this out, and FOD?
Functions on Demand.

In my opinion a way for Audi to make people pay more for things that should have been included as standard (ie speed limit recognition).

According to my dealer though, apparently in the future all Audi's will come built with things like the matrix headlights as standard and then they will need to be activated via FOD.
 

SamB2020

Active Member
@NIKLDN
Touch wood upto yet I’ve not had the SOS malfunction.
cars been back a week and nothing strange or any faults since the garage had it for two weeks.
 

NIKLDN

A3 8Y 1.5 TFSI Edition 1
@NIKLDN
Touch wood upto yet I’ve not had the SOS malfunction.
cars been back a week and nothing strange or any faults since the garage had it for two weeks.
Great stuff? Any chance you can get a report on what they did so that I can throw this as the dealership when I go to see them?
 

NIKLDN

A3 8Y 1.5 TFSI Edition 1
Functions on Demand.

In my opinion a way for Audi to make people pay more for things that should have been included as standard (ie speed limit recognition).

According to my dealer though, apparently in the future all Audi's will come built with things like the matrix headlights as standard and then they will need to be activated via FOD.
@auzzam_crd and @Nothingdoing079

2C6015A2-6882-44AA-AE97-C261FC3795DB.png
 

Nothingdoing079

Registered User
I think those might actually be Audi production codes.

Doing a quick Google search U5B looks to be the PR code for the Instrument Cluster, which I've got listed in my myaudi as "Instrument Cluster, mph speedometer -great britian-

I would imagine the others correspond to similar codes. .

FYI this what I see for mine

Screenshot_20210320-080751_myAudi.jpg
 

NIKLDN

A3 8Y 1.5 TFSI Edition 1
Spoken to two Audi Dealerships near me and managed to get the car booked in for Friday coming!

One have explicitly said that they have had two software updates from Audi to get rid of the malfunction and neither worked, so they’re waiting for a fix.

The other dealership have said they will get a technician to have a look at the car, no mention of any updates but the agent booking me in mentioned ‘Apple car play’ before I could even mentioning anything (assuming they’ve had others complain about this lol)

Hoping that yesterday’s frozen screen was a one off. Was stuck on the screen for ages!

4125A52F-57D7-4867-81DB-640932B16112.jpeg
 

vianez

New Member
Hi Guys, update from my side. Audi Italy tell (not the dealer) told me that the will try to their best to fix this thing and the S-Performance visualization is because of the first model producted. I told them that is not a valid excuse for having an unstable mmi.

Now i will talk back to the dealer and see if the are able to change it with the new version.
 

NIKLDN

A3 8Y 1.5 TFSI Edition 1
Hi Guys, update from my side. Audi Italy tell (not the dealer) told me that the will try to their best to fix this thing and the S-Performance visualization is because of the first model producted. I told them that is not a valid excuse for having an unstable mmi.

Now i will talk back to the dealer and see if the are able to change it with the new version.
What problems are you having? And which firmware are you running?
 

vianez

New Member
S3 8Y with version 3272.
No S-Performance Layout
MMI Crash
No Audi Connect User Login
No Apple Car Play
Apple Car Play Black screen / Flickering
 
S3 8Y with version 3272.
No S-Performance Layout
MMI Crash
No Audi Connect User Login
No Apple Car Play
Apple Car Play Black screen / Flickering
You won't get the S-Peformanace layout assuming your talking about the Virtual Cockpit as you only get this with Virtual Cockpit Plus which Audi deemed not worthy for the hot hatch S3 but ok for the 1.5T Edition 1 model as standard
 

Santiago

Registered User
You won't get the S-Peformanace layout assuming your talking about the Virtual Cockpit as you only get this with Virtual Cockpit Plus which Audi deemed not worthy for the hot hatch S3 but ok for the 1.5T Edition 1 model as standard
I think Vianez is in Italy, so who knows what comes as standard in the S3 over there?
 

SamB2020

Active Member
@SamB2020 @Riding Air @Nothingdoing079,

how you all getting on with your cars, still issues with MMI or?
@NIKLDN
Upto yet no real issues to speak of.
Only thing is if I plug my iPhone in and then start the car the mmi takes ages to boot up and sometimes looses the user settings but if I switch car on wait till it boots then plug iPhone in I get no issues.
It’s not very often I use CarPlay so no big deal.
Cars been back with me 11 days so hopefully the woes are over.
 

vianez

New Member
Hey guys, do you wanna see something new? Look at the brake... 6000 km......
This is the original red brake for S3 in option.... Looks amazing...
 

Attachments

  • Foto 23-03-21, 18 33 13.jpg
    Foto 23-03-21, 18 33 13.jpg
    1.7 MB · Views: 83

KXL

Active Member
Spoken to two Audi Dealerships near me and managed to get the car booked in for Friday coming!

One have explicitly said that they have had two software updates from Audi to get rid of the malfunction and neither worked, so they’re waiting for a fix.

The other dealership have said they will get a technician to have a look at the car, no mention of any updates but the agent booking me in mentioned ‘Apple car play’ before I could even mentioning anything (assuming they’ve had others complain about this lol)

Hoping that yesterday’s frozen screen was a one off. Was stuck on the screen for ages!

View attachment 233618
Wait..the buttons on the side of the hazards don't light up at night even when headlights are on? Or do they only light up when MMI is not frozen? Also AC controls not a single (on button) lit up? How do you know where to press at night if off? FYI I haven't received my A3 yet, so I don't know if this is normal or not.
 

Nothingdoing079

Registered User
Wait..the buttons on the side of the hazards don't light up at night even when headlights are on? Or do they only light up when MMI is not frozen? Also AC controls not a single (on button) lit up? How do you know where to press at night if off? FYI I haven't received my A3 yet, so I don't know if this is normal or not.

The AC display lights up but the buttons under the display don't.

The thinking is that the display highlights where the buttons are, however in reality I personally find it a pain when trying to change temp at night as you almost have to guess where the button is
 
Wait..the buttons on the side of the hazards don't light up at night even when headlights are on? Or do they only light up when MMI is not frozen? Also AC controls not a single (on button) lit up? How do you know where to press at night if off? FYI I haven't received my A3 yet, so I don't know if this is normal or not.
Effectively each buttons lines up with the display above it so Audi have decided to do away with lighting up the button - Part of many penny pinching savings I'm afraid
 

KXL

Active Member
The AC display lights up but the buttons under the display don't.

The thinking is that the display highlights where the buttons are, however in reality I personally find it a pain when trying to change temp at night as you almost have to guess where the button is

Effectively each buttons lines up with the display above it so Audi have decided to do away with lighting up the button - Part of many penny pinching savings I'm afraid

Oh I see, well could be worse, could have been an all touch screen AC unit and that to me personally would be a great PITA.
But the 'drive select/startstop/tractioncontrol and park assit buttons either side of the hazards also don't light up and we also need to 'guess' where it is as well at night?
 
Oh I see, well could be worse, could have been an all touch screen AC unit and that to me personally would be a great PITA.
But the 'drive select/startstop/tractioncontrol and park assit buttons either side of the hazards also don't light up and we also need to 'guess' where it is as well at night?
I thought they did light up because the heated rear screen buttons etc do - It was only the ones that had a display - Lights have to be on obviously - Are the display lights dimmed in the MMI

To be fair I've not driven mine much at all let alone at night since I've had it as have the works pool car at present rather than leave it at the office - Had it a year now!!
 

Nothingdoing079

Registered User
Oh I see, well could be worse, could have been an all touch screen AC unit and that to me personally would be a great PITA.
But the 'drive select/startstop/tractioncontrol and park assit buttons either side of the hazards also don't light up and we also need to 'guess' where it is as well at night?

The Drive select etc all lights up. It's just the AC controls that don't
 
The Drive select etc all lights up. It's just the AC controls that don't
I’ve attached a photo of the interior of my S-Line centre console at night. All buttons are lit except the ones that are associated with the aircon indicators. Personally, I don’t have any trouble finding those buttons at night, as they are directly below their corresponding displays and have a “metallic” edge trim. The most commonly used switches - the temperature controls - are at each end, making them the easiest to locate. The next most used is the one in the middle, so again easy to locate. The two least used - assuming the aircon is in Auto Mode - are the least easy to locate (I’ll admit I haven’t tried as I very rarely use them). It’s almost as though Audi’s engineers and designers have given this some thought ;-)

If you have trouble finding the buttons and are in the car on your own then it’s a doddle to use a voice command to adjust the temperature. (I’m impressed with the voice recognition, it’s up there with Alexa for accuracy - if not more so.)
 

Attachments

  • C99143ED-0379-44CB-8B0E-4423F0AB077A.jpeg
    C99143ED-0379-44CB-8B0E-4423F0AB077A.jpeg
    2.5 MB · Views: 71
Last edited:

KXL

Active Member
I never realised that voice commands could control the AC.

That's very helpful and will be giving it a try
Maybe I remember one reviewer on youtube comment 'Hey Audi, I'm cold' and the car increased the temp.
 
Maybe I remember one reviewer on youtube comment 'Hey Audi, I'm cold' and the car increased the temp.
“Hey Audi” might have to be enabled in the settings? I reckon that the easiest method of accessing voice control is a short press on the steering wheel button.
 

S3 TRS

Registered User
Hey guys, do you wanna see something new? Look at the brake... 6000 km......
This is the original red brake for S3 in option.... Looks amazing...

I would take that back to the dealer and get them to sort that out. You paid extra for it and it’s flaking off! Not good.


Sent from my iPhone using Tapatalk
 

Nothingdoing079

Registered User
I’ve attached a photo of the interior of my S-Line centre console at night. All buttons are lit except the ones that are associated with the aircon indicators. Personally, I don’t have any trouble finding those buttons at night, as they are directly below their corresponding displays and have a “metallic” edge trim. The most commonly used switches - the temperature controls - are at each end, making them the easiest to locate. The next most used is the one in the middle, so again easy to locate. The two least used - assuming the aircon is in Auto Mode - are the least easy to locate (I’ll admit I haven’t tried as I very rarely use them). It’s almost as though Audi’s engineers and designers have given this some thought ;-)

If you have trouble finding the buttons and are in the car on your own then it’s a doddle to use a voice command to adjust the temperature. (I’m impressed with the voice recognition, it’s up there with Alexa for accuracy - if not more so.)

So I tried to use voice commands today to adjust the heating and all the MMI seemed to do was go to navigation and look up the number 20 (when I asked for heating to be set to 20).

What command do you say when you want to control the temp as so far I'm having no luck getting this to work, and am wondering whether the difference in the MMI version might also affect this.

I also can't find anyway to enable "hey Audi"
 
So I tried to use voice commands today to adjust the heating and all the MMI seemed to do was go to navigation and look up the number 20 (when I asked for heating to be set to 20).

What command do you say when you want to control the temp as so far I'm having no luck getting this to work, and am wondering whether the difference in the MMI version might also affect this.

I also can't find anyway to enable "hey Audi"
I seemed to remember you said increase or lower temperature and it changed it by 1 degree rather than specify a temp but not certain
 
So I tried to use voice commands today to adjust the heating and all the MMI seemed to do was go to navigation and look up the number 20 (when I asked for heating to be set to 20).

What command do you say when you want to control the temp as so far I'm having no luck getting this to work, and am wondering whether the difference in the MMI version might also affect this.

I also can't find anyway to enable "hey Audi"
I can’t remember the precise words that I used, I really didn’t give it much thought: I just asked the car to set the temp that I wanted. I’ll give it another try when I collect my groceries this evening.

Sorry I can’t remember where the voice recognition settings are, I came across them whilst exploring them all, rather than seeking them out. It might be worth a look in the manual. (There’s also a setting that improves the voice recognition accuracy by allowing the car to use the cloud. I can’t remember whether or not I’d yet enabled that when I used it.)
 
Last edited:

Ludus

Active Member
So I tried to use voice commands today to adjust the heating and all the MMI seemed to do was go to navigation and look up the number 20 (when I asked for heating to be set to 20).

What command do you say when you want to control the temp as so far I'm having no luck getting this to work, and am wondering whether the difference in the MMI version might also affect this.

I also can't find anyway to enable "hey Audi"
Say "I'm cold/hot"
 
I can’t remember the precise words that I used, I really didn’t give it much thought: I just asked the car to set the temp that I wanted. I’ll give it another try when I collect my groceries this evening.
Here’s a few different phrases for adjusting temperature. The last command was an attempt to switch the climate control off, which didn’t quite work but shows that the air con mode can also be adjusted. Whilst not on video, during the drive I’d used the voice interface to switch off the heated seats. The voice system seems pretty natural to me (although Audi’s English accent isn’t as fluid as Alexa or Siri).
 

Nothingdoing079

Registered User
So I've tried everything I can think of and can't get voice control to work with the AC

Looks like another thing I'm unable to do with this version of the MMI
 
Top