No air out of windscreen vent

Rolling Thunder

Registered User
Hey guys,

I recently purchased this car and tried to de-mist the windscreen but there is no air coming out the vent. I sense a flap is frozen shut somewhere as all the other vents are fine. Where do I need to look please?
 

marktdisport

Registered User
also you can do a temp fix by removing the glove compartment and remove green motor and open it manually and save yourself 90quid or so if times are hard 15 minute job..... i just used a small zip tie to hold it open works fine now
 

SMc

Registered User
I was about to post about a similar problem....and I found this thread very very helpful......

http://www.audi-sport.net/vb/a4-a4-cabriolet-s4-forum-b6-chassis/49307-help-windscreen-demister.html

However, Not only do I have the demister not working, but the passenger side only blows out freezing cold air, whatever temperature you set. The driver's side works perfectly though.

Does anyone else have this too? I assume it is all linked but just need to know if there's any additional work to do as my situation is more than just the demister?

Cheers

S
 

wazz

Registered User
I just changed the pollen filter and that's made a difference.
 

jbcalvin

Registered User
SMc....

It is either a failure of the heater flap motor for the passenger side, or the aircon control unit itself, I replaced all the motors with ones from a B7 and was still getting cold air on the drivers side, changed the control unit and sorted it....
 

marktdisport

Registered User
the demist flap is a different issue to your temp fault m8, the flap is the motor failing old/weak....
 
Top