Problem after retrofit heated seats 2006 Audi S3 8P

Alvigu95

Registered User
Hello, after using the thread to recondition heated seats in my prefacelift audi s3 8p 2006, I had a problem with the climatronic because it does not release air with the AC on, in the ECON mode if it releases air perfectly in all positions and speeds. The climatronic has reference 8P0 820 043 AH5 PR. I have tried to make basic adjustments in the HVAC module, without result. The fault that appears to me in vagcom is 03271 - Installation of the positioning motor for the backpressure cover. From the conclusions I've drawn, I think my climatronic is too new and it does not work in my older car, could that be the problem? I need to fix it as soon as possible the heat is getting closer, please, if someone can help me, I would be very grateful. Thanks and greetings from Spain.
 

NHN

Retrofitter - Audi - VW - Skoda - Seat
Site Sponsor
VCDS Map User
Pics of new unit please.

If it has ac button instead of econ it won't work.
 

Alvigu95

Registered User
this is the unit when I was installing everythin
 

Attachments

  • 2B5FD1AE-AFAD-4271-96CC-DDE3E0CE8F87.jpeg
    2B5FD1AE-AFAD-4271-96CC-DDE3E0CE8F87.jpeg
    947.1 KB · Views: 413

Alvigu95

Registered User
Pics of new unit please.

If it has ac button instead of econ it won't work.
the unit is the same as the one that the car had, only that it has the roulettes of the seats, with ECON button, both units are of the prefacelift model
 

NHN

Retrofitter - Audi - VW - Skoda - Seat
Site Sponsor
VCDS Map User
What's the date of the new unit?
 

NHN

Retrofitter - Audi - VW - Skoda - Seat
Site Sponsor
VCDS Map User
Mid 07 was changeover point where the system became a cam & 1 motor instead of 2 motors so I suspect its too new for your car, the econ button setup may have changed too as it became an AC button later, try another earlier unit & I believe it will work.
 

NHN

Retrofitter - Audi - VW - Skoda - Seat
Site Sponsor
VCDS Map User
Its very interesting, as I heard a whisper new climate units could be adapted coding wise somehow to work with older cars but havnt found any way to do it, as basic setting 001 doesnt help the issue.
 

Alvigu95

Registered User
Its very interesting, as I heard a whisper new climate units could be adapted coding wise somehow to work with older cars but havnt found any way to do it, as basic setting 001 doesnt help the issue.
I have to get an older unit with heated seats. his original works perfectly everything, curiously this new with the activated ECON, the trapdoors and motors work, when deactivating the ECON, it is as if the trapdoors were closed and only the ventilation engine works, you can hear how the air moves but nothing comes out if the new unit is really not worth it, because with the activated ECON works perfectly? thank you very much everyone for the answers I hope to get to fix it!
 

Robin Chandler

Registered User
I think my unit is from a car in Europe. After installing it all with the correct loom and instructions my buttons are the wrong way around! Left roller heats drivers seat. Also the dual heat control can only be adjusted from left dial. :blink: Got used to it now and cant be bothered to change it!
 

Robin Chandler

Registered User
Its very interesting, as I heard a whisper new climate units could be adapted coding wise somehow to work with older cars but havnt found any way to do it, as basic setting 001 doesnt help the issue.

If someone managed to do this would that mean you could fit the Q3 one in the 8P3? I'd love the white display in mine.
 

NHN

Retrofitter - Audi - VW - Skoda - Seat
Site Sponsor
VCDS Map User
I think my unit is from a car in Europe. After installing it all with the correct loom and instructions my buttons are the wrong way around! Left roller heats drivers seat. Also the dual heat control can only be adjusted from left dial. :blink: Got used to it now and cant be bothered to change it!

You need to do a basic setting 001 to correct the rhd issue & if its a retrofit heated seats swap your wiring round.
 

Alvigu95

Registered User
Hello everyone, today I removed the new unit that was giving me problems, I placed the one that had the car and everything works perfectly as always, I imagine that the problem comes from the new unit. I will leave the photos of the references of both units, the oldest is the one that had the car and the newest one that I bought with heated seats. I hope someone can tell me what should be right for my car. It has 2DIN with RNSE oem, and now heated seats. Thank you all
IMG_4260.PNG
IMG_4264.JPG
 
Last edited:

Alvigu95

Registered User
Can anyone tell me the age limit of the unit with heated seats? I have seen a couple of them at a good price of A3 8p 2003/2004 by ebay, would they be fine for my car? the reference of a unit of the announced 2004 is, 8P0820043E
 

NHN

Retrofitter - Audi - VW - Skoda - Seat
Site Sponsor
VCDS Map User
Mid 07 was the change point, so I'd say anything 06 & before.
 

Alvigu95

Registered User
Hello everyone, one year after starting the project, I'm done. In the end the problem was the climatronic reference, I already have the resistances inside the seats and it works. But not as I would like. The seat bases heat up perfectly, the problem comes with both backrests, which heat very little or nothing. In vagcom I get the error 02092. Any ideas? thank you very much!
 

NHN

Retrofitter - Audi - VW - Skoda - Seat
Site Sponsor
VCDS Map User
They use the same circuit as the bases iirc without checking schematics, check wiring & do a continuity test on the back rest circuits.
 

Alvigu95

Registered User
After using them to test them more times, the pilot works well, I need to check the backrest of the passenger seat, they have left me a laser thermometer for the checks. thanks for the support!
 

NHN

Retrofitter - Audi - VW - Skoda - Seat
Site Sponsor
VCDS Map User
Just use your hand, stick on 6 & test, no need for thermometer tbh, make sure passenger seat has weight on the base incase it has occupancy sensor fitted.
 

Alvigu95

Registered User
I did the tests today, both seats heat all their parts. But the co-pilot is noticeably less hot than the pilot. The passenger with 6 heats up as the pilot in 3. Could it be a problem on the ground point? In vcds, the only error that marks me is 02092 - Enable heated seats, open or short to the ground, which I have not found information to solve.
 
Top