Radiator fans won't stop running (Fan Control Module)

iiiiicks

Registered User
Hi everyone, I have what seems to be a common problem which is my radiator fans won't stop running, slowly, (both of them) even with the ignition key off and the engine cold and air-con off.

(If I try to turn the air-con on the econ light stays on and I'm unable to turn econ off.) But I don't care about the air-con, all I want is the cooling system AND THE FANS to be operational, at least for now.

Now, that being said I have a question.

I have a 2004 Audi A3 SE TDI 2.0. (I believe it's an 8p1)

If the problem really is the "fan control module", and I believe it is. Is the "fan control module" also on the back of the biggest fan for my car's model being from 2004 or is it elsewhere?

I'm asking this because on the back of the biggest fan of my car there is no heat-sink like in some models, mine only has the motor housing and it has holes.

So my question is simple. Can someone confirm that the "fan control module" is also on the back of the biggest fan for my 2004 Audi A3 even though it doesn't have a heat-sink?

( I think 2006 onward models have that heat-sink, not sure).


Here is a picture of fans similar to mine (these are similar, not from my car but the back of the fans look the same):

https://www.audiforums.com/forum/attachment.php?attachmentid=22450&stc=1&d=1500657393

Here is a picture of those with the heat-sink:


https://www.audiforums.com/forum/attachment.php?attachmentid=22451&stc=1&d=1500657393

Kind regards

Icks
 

Attachments

  • Radiator fans.jpg
    Radiator fans.jpg
    34.8 KB · Views: 614
  • FA720807_main-3.jpg
    FA720807_main-3.jpg
    109.2 KB · Views: 832

ch1z64

C'mon you's bhoy's in Green
VCDS Map User
Silver Supporter
Hi everyone, I have what seems to be a common problem which is my radiator fans won't stop running, slowly, (both of them) even with the ignition key off and the engine cold and air-con off.

(If I try to turn the air-con on the econ light stays on and I'm unable to turn econ off.) But I don't care about the air-con, all I want is the cooling system AND THE FANS to be operational, at least for now.

Now, that being said I have a question.

I have a 2004 Audi A3 SE TDI 2.0. (I believe it's an 8p1)

If the problem really is the "fan control module", and I believe it is. Is the "fan control module" also on the back of the biggest fan for my car's model being from 2004 or is it elsewhere?

I'm asking this because on the back of the biggest fan of my car there is no heat-sink like in some models, mine only has the motor housing and it has holes.

So my question is simple. Can someone confirm that the "fan control module" is also on the back of the biggest fan for my 2004 Audi A3 even though it doesn't have a heat-sink?

( I think 2006 onward models have that heat-sink, not sure).


Here is a picture of fans similar to mine (these are similar, not from my car but the back of the fans look the same):

https://www.audiforums.com/forum/attachment.php?attachmentid=22450&stc=1&d=1500657393

Here is a picture of those with the heat-sink:


https://www.audiforums.com/forum/attachment.php?attachmentid=22451&stc=1&d=1500657393

Kind regards

Icks
the big fan should have a lead which you plug in , now i found that the one i bought from eurocar parts the plug cover had to be changed by using the old one and then all was ok . hope that answer your question about the fan
 
Top