S4 Probs :(

smitch

Registered User
My S4 revs fine up to 5000 rpm then will not rev any further in any gear!!! :sadlike:

Any ideas guys??? :uhm:


By the way, it's a 98 2.7v6 twin turbo......
 

GSB1

Registered User
MAF?

Where are you? Get a vagcom fault scan.
 

smitch

Registered User
Cheers boys, iwas thinking it might be one of the turbos or something nasty.

Got it booked into my local specialist in guildford but they can't look at it til the 26th.

Fortunately i hardly ever drive so i can handle it but i've only just bought the ****** thing!!!
 

EssVier

There ain't no party like an S-Club Party.
Me being thick, but is the MAF easy to replace? And is there just the one? I like preventative maintenance. Maybe I just like me trousers being taken down and have a spanking from Herr Audi! :asskicking:
 

Blue_Thunder

Registered User
Me being thick, but is the MAF easy to replace? And is there just the one? I like preventative maintenance. Maybe I just like me trousers being taken down and have a spanking from Herr Audi! :asskicking:


We only have one MAF on the S4 and it's an easy job to replace if you can turn a screwdriver (both anti-clockwise and clockwise mind), pull out/push in a plug and have opposable digits.
:thumbsup:
 

macca

Registered User
i'm near gatwick, if you want me to pop over sometime smitch and you are not far from guildford, i'd be happy to scan vag com through it to see if any error codes. on my 1.8T it doesn't pick up maf errors, or atleast didn't when i broke mine, but S4's it may do.
 

macca

Registered User
PM me you r contact number and where you are roughly and i'll get hold of you, i also pm you my phone number
 
Top