Speedo and fuel guage going crazy....

g60go

Registered User
Can someone point me in the direction of what the most likely cause is because I don't really have a lot of time to be messing about changing stuff and waiting for parts to arrive. I'm driving through Europe to Budapest in a week and a half and a few days ago my speedo started going crazy,just fluctuating up and down all over the place,and the other day I ran out of fuel in the car although the dials were still reading 10mls left in the tank,which I thought was strange,then ever since the fuel guage and fuel indicator have been going mental,the guage will say empty and 0mls left,I'll put £15 in it,then it'll say 135mls in it,then 10 seconds later it'll just down to 35mls,then back up to 80mls.....just on and on like this. Can't drive it through Europe like this,need it fixed in next few days,can anyone throw me any suggestions that genuinely could be the problem? Thanks!
It's an S3 8L by the way,thanks!
 

badger5

www.badger5.co.uk
Site Sponsor
check speedo output is plugged in on gbox
 

g60go

Registered User
Just been out there badger,removed Airbox and had a look. The connector is FIRMLY connected,unplugged it and plugged it back on.
I will say though, a few months ago,one day when it was raining really heavy,my speedo started doing the same thing,then it stopped going crazy and went back to normal the next day and stayed like this,but then again when I drove it on another really wet day it did the same. Now it's just doing it constantly. Is it a dodgy speedo sensor,and if so,is this controlling the fuel guage/fuel amount counter on the dash??? Thanks for the reply!
 

g60go

Registered User
Bill you might actually be the MAN!
Just been down the road in it and the speedo hasn't skipped a beat once and fuel guage isn't talking sh17 to me either. It was firmly connected but I think there may have been a trace of oil in there or something,seemed very wet with oil so I'll remove it again tomorrow at work and spray some contact cleaner into it,cheers!
 

badger5

www.badger5.co.uk
Site Sponsor
the speedo is attached to the fuel gauge for reasons of buffering the fuel level sender output (I guess)
Seen it before.. a good clean up and replug may just bring it back to life if there's a bunch of oil and damp around it perhaps
 

g60go

Registered User
Yeah that seems to have done the trick bill! Went out in it for an hour this afternoon and its spot-on again. Thanks again!
 

Schlaag

Bwah
Guys where abouts is the speed sensor on the gearbox? and what has to be removed to locate/replace? (just latching on to this from a search rather than make a new post ) thanks
 

Solberg

Registered User
I question this aswell, I have one plug on the "back" of the gearbox behind the TIP close to the firewall, and one right under the battery casing... Which one is it?
 

Solberg

Registered User
Know what the one in front is for? under the battery, mine is loose, no idea what its for, but its going into the gearbox with a 2 wire plug.
 

<tuffty/>

Badger 5 Edition...Its all about the flow...
Staff member
Moderator
Know what the one in front is for? under the battery, mine is loose, no idea what its for, but its going into the gearbox with a 2 wire plug.
Only other electrical component on the gearbox is the reversing light switch... this is starter motor side of the box..

<tuffty/>
 

Schlaag

Bwah
Amazon are selling a Febi ones for £13. Bargain
 

Schlaag

Bwah
This one yah?

61U7trFTFtL._SY355_.jpg
 

Schlaag

Bwah
Aah thanks Tuffty. RE its location, It's not located here is it? Seems a right pain to get to...

I couldnt see anything else on the gearbox and this was with the airbox removed...

kMik0qD.jpg


FukPXLl.jpg
 

Solberg

Registered User
Thats the one infront, reckon you have to take off the TIP and its located all the way in the back.

Sent fra min SM-G925F via Tapatalk
 

Schlaag

Bwah
Thank you mate
 

Solberg

Registered User
Okay I bought what i tought was that sensor Paulie, but the one I got looks like this:

https://www.ebay.com/itm/FOR-AUDI-A...002718?hash=item3d5f02795e:g:oHwAAOSwJ4hY-JkK

But the one on my 02M gearbox where you show on the last picture, when I take it out it looks like this:

https://www.ebay.com/itm/Genuine-Di...m=263565962238&_trksid=p2045573.c100033.m2042


Fill me out? Is the latest one the correct one and what the heck is the one I bought with the red gear on it for? When I fill out S3 8L or TT 1.8T 225hp in the "does this fit my car" section on ebay it says it wont fit my car lol...
 
Top